E-Mail Do-Not-Send Checking
$dns_email pathname|databasespec|FailAll [code] [domain|combined] [EmptyOK] [WSDelim]
This command is used in a Job Administration UJP file to specify a do-not-send look-up file for use at launch time for e-mail items. The command may also be placed in an FS Template file (.FST) for use in an FFBC launch. Multiple commands may be supplied, and commands from System, Owner and Jobtype UJP files migrate to the job instance properties in the usual way.
 | The same pathname should only be used once in a set of lookup files. |
The advantages of the launch-time do-not-send and white-list commands are described in the Configuration topic and an overview appears in Launch-Time Do-Not-Send Checking.
The parameters on this command are used as follows:
| pathname | The pathname of the look-up file to be used. Currently supported file extensions are: |
| .NDX | a character-mode index file created and maintained by the CFUTIL PIN utility. |
| .TXT | a list of entries to be matched |
| databasespec | The components of the database specifier are separated by the vertical bar symbol (|) and are described in more detail in the description of the do-not-send feature. |
| Database Name | The full pathname of a supported database, or a DSN source |
| Table Name | The name of the table to use (default table name: DNS) |
| Key Field Name | The name of the key field to use (default key field RECIPIENT) |
| Timeout Value | Timeout for look-up (defaults to ADO default value) |
| Data Field Name | The name of the data field to use from the matched entry. |
| FailAll | A keyword which indicates that all addresses and domains are to be failed. In this case only those addresses and/or domains in a whitelist (if any) specified by a $whitelist_email command will be used. This keyword must be the first or only parameter on the command (a code may follow it). |
| code | A code which will be used to override the default failure outcome code for matched items. In a 'combined' index/list, the supplied code will be incremented by one for domain-name matches. The default values are 189 for e-mail address matches and 190 for domain matches. The code range 200-249 is suggested for custom outcome codes. If you use the override outcome code on the command, failed items will NOT be protected from accidental transmission if you ignore the warning and enter 'Z' on the JOBADMIN Resubmit Fail dialog. |
| domain | A keyword which indicates that the index/list contains only domain names to be matched |
| combined | A keyword which indicates that the index/list contains both e-mail addresses and domain names |
| EmptyOK | A keyword which indicates that the index/list may be empty. This suppresses the check that ensures that at least one entry has been loaded from the file. Failure to load any entries could be a symptom of a corrupted file. |
| WSDelim | A keyword which indicates that any number of white spaces may separate the phone number and the DNS_DATA code in a loaded TXT list. |
Items matched in a $whitelist_email specification in the same file will not be checked.
The NDX file may contain a positive numeric data value for each entry, the TXT file may contain a positive numeric data value separated from the address/domain entry by a single TAB character (or any whitespace, if WSDelim is used), and the database data field may also contain a numeric value. If present and greater than one the value will be saved as the value of a variable named DNS_DATA in the launched FS file.
When multiple commands are specified, items will be checked in the order of System, Owner and Jobtype entries and in the reverse sequence to that in which they appear in each file. The outcome code reported will be that of the file in which the item was first matched, if specified. In an FEB2 broadcast type (two list columns) a matched item will be rejected even if e-mail transmission was specified to occur second.
Default: No launch-time checking will be performed.
Examples:
$dns_email @FFBASE\dnsemail.ndx 200
If you use the default global look-up file DNS_MAIL.NDX on this command (rather than a custom look-up file) you should disable the transmit-time look-up in the same file. This is done as follows:
$dns_email @FFLOG\DNS_MAIL.NDX ; use DNS_MAIL.NDX look-up at launch time
$var_def DNS_MAIL_PATH none ; suppress send time DNS_MAIL.NDX look-up